IT-Service GmbH 


spica.ulm.go-itservice.de

stormrunner(beta) Standard mit Debian 4.0 Etch, Update auf 5.0 Lenny

Hardware:

Identisch zu antares, Abweichung:
Speicher1024 MB DDR2/PC 667

Abweichungen

Da antares ursprünglich eine SATA Platte enthielt, gab es nach direktem Kopieren der Systemplatte Probleme mit dem Finden des root-Filesystems. Deshalb wurde der Rechner analog zu antares neu installiert und nicht wie pollux kopiert. Damit man die Pakete nicht manuell auswählen muß, was der langwierigste Teil der Installation ist, kann man diese auslesen und allesamt am Zielrechner auswählen.
Dazu am Quellrechner (antares) die Paketliste erstellen und mit scp auf den Zielrechner kopieren:
# dpkg --get-selections > antares.txt
# scp antares.txt root@spica:/root
Am Zielrechner (spica):
# dpkg --set-selections < antares.txt
# apt-get dselect-upgrade
Die restliche Installation geht analog zu antares, auch zwischen der inzwischen als stable markierten Version von etch und dem bei antares verwendeten RC1 ist kein merklicher Unterschied. Damit Benutzer ec nicht manuell angelegt werden müssen, werden folgende Dateien/Verzeichnisse von antares kopiert:
/etc/profile
/etc/passwd
/etc/shadow
/etc/group
/etc/init.d/obi1
/etc/apt/sources.list
/root/
Dann werden noch einige Links angelegt:
# ln -s /etc/init.d/obi1 /etc/rc2.d/S99obi1
# ln -s /etc/init.d/obi1 /etc/rc3.d/S99obi1

Update von Debian Etch (4.0) auf Lenny (5.0)

Den Update von Sarge (3.1) auf Etch (4.0) habe ich einige Male durchgeführt, vollkommen problemlos. Der Upgrade von Etch (4.0) auf Lenny (5.0) war etwas holpriger, lag vielleicht auch daran, daß der erste umgestellte Rechner ein Desktop war. Ich musste den apt-get dist-upgrade einige Male aufrufen, abwechselnd mit apt-get -f install. Zu Begin erfolgte sofort ein Abbruch, die Key-Rings waren veraltet.
In der /etc/apt/sources.list werden die Zeilen für Etch(sinngemäß) durch Lenny oder Stable ersetzt :
deb ftp://ftp.uni-bayreuth.de/pub/linux/Debian/debian/ lenny main contrib non-free
deb-src ftp://ftp.uni-bayreuth.de/pub/linux/Debian/debian/ lenny main contrib non-free
deb http://security.debian.org/ lenny/updates main contrib non-free
deb-src http://security.debian.org/ lenny/updates main contrib non-free
deb http://ftp.debian-unofficial.org/debian stable main contrib non-free restricted
# apt-get update
# apt-get install debian-archive-keyring
# apt-get dist-upgrade
Diverse Fragen des Debian-Installers folgen, bei mir konnten überall die Default-Antworten übernommen werden ... Mehrere Runden:
 
# apt-get -f install
# apt-get dist-upgrade
Eine der Runden erfolgte z.B. wegen via NFS eingehängten Verzeichnissen, eine wegen dem mysql-server, da musste ich sogar neu booten! Wo gibts den sowas, bei nem Betriebssystemupdate zwischendrin neu booten zu müssen! Erinnert mich irgendwie an ... ich komm nicht drauf?

Problem mit X11
das Program 915resolution ist bei Lenny nicht mehr dabei und wird auch nicht mehr benötigt. Allerdings musste ich in meiner manuellen xorg.conf das Ausschalten des DDC rückgängig machen und einige Daten, die ich mit dem Tool hwinfo --monitor herausbekommen habe, einfügen. Die relevanten Sektionen sind also:
Section "Device"
	Identifier	"Intel Corporation Mobile 945GM/GMS/940GML Express Integrated Graphics Controller"
	Driver		"i810"
	Option	 	"MonitorLayout" "CRT,LFP"
	VideoRam 	131072
	BusID		"PCI:0:2:0"
EndSection

Section "Monitor"
	Identifier	"SyncMaster"
	Option		"DPMS"
	HorizSync	30-81
	VertRefresh	56-60
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"Intel Corporation Mobile 945GM/GMS/940GML Express Integrated Graphics Controller"
	Monitor		"SyncMaster"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1920x1200" "1280x960"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1920x1200" "1280x960"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1920x1200" "1280x960"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1920x1200" "1280x960"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1920x1200" "1280x960"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1920x1200" "1600x1200" "1280x960"
	EndSubSection
EndSection

Section "Modes"
        Identifier   "Modes[0]"
        Modeline        "1920x1200" 154.00 1920 1968 2000 2080 1200 1200 1209 1235
EndSection
Die 1600x1200 Einstellung ist für einen anderen Monitor gedacht.

Einige Software verhielt sich nach dem Upgrade nicht wie gewohnt:

  • GIMP Icon neu auf die Startleiste ziehen
  • Open Office openoffice.org neu installieren (mit aptitude). Ich weiss nicht warum, unter etch war 2.0 ganz normal installiert. Kann aber auch an den Abbrüchen des dist-upgrade gelegen haben.
  • virtualbox Hatte ich aus einer Extra Quelle in der sources.list, nämlich deb http://www.virtualbox.org/debian etch non-free, was es unter Lenny so nicht mehr gibt. Mit aptitude folgende Pakete installieren:
    virtualbox-ose
    virtualbox-ose-guest-modules-2.6.26-1-686
    virtualbox-ose-modules-2.6.26-1-686
    Beim ersten Start werden die Konfigurationen auf ein neues Format konvertiert, keine Probleme. Icon wieder in die Startleiste
  • eclipse 3.2 stürzt beim Start nach dem Upgrade mit einer Fehlermeldung ab. Recherche im Internet ergab diveres Lösungsmöglichkeiten. Mehrere probiert, wieder zurückgestellt ec. Letztendlich funktionierte eclipse und das installierte php-eclipse wieder, nachdem ich sun-java6 als VM verwende.
    Also folgende Pakete installieren. Ob man xulrunner-dev wirklich braucht, weiss ich nicht, der blieb von der Testorgie übrig:
    xulrunner-dev
    sun-java6-jre
    Dann noch in der /etc/eclipse/java_home Java 6 als Default eintragen, also nach oben hin:
    /usr/lib/jvm/java-6-sun
    ..
    
    Schon läuft Eclipse wieder
  • Mehr Probleme habe ich nicht festgestellt.

    Einbau Graphikkarte ATI Radeon 4670

    Da ich mehr 3D-Graphikleistung brauche als die i810-kompatible On-Board_Graphik des ASUS N4L-VM DH Motherboards hergibt, habe ich einige Zeit herumgesucht und mich für eine lüfterlos ATI Radeon HD 4670 entschieden.
    Nach einigen Problemen mit der selbstgebauten /etc/X11/xorg.conf verwendete ich das Kommandozeilentool aticonfig --initial, wodurch die xorg.conf angepasst wurde. Allerding schickte ein Umschalten auf den 2. Screen oder auf eine Konsole (z.B. via <CTRL><ALT><F1>) den Rechner immer noch ins Nirvana, auch kein Ping von aussen war mehr möglich. Nach einigem Probieren habe ich den 2. Screen in der /etc/gdm/gdm.conf herausgenommen, worauf die Umschaltung funktionierte.
    FAZIT: Keinen zweiten Screen konfigurieren, sonst kommt der fglrx Treiber durcheinander!!!
    Eigentlich wollte ich den Open-Source radeonhd Treiber verwenden, der unterstützt die HD 4670 aber (noch) nicht.
    Ein Problem ist noch geblieben: Obwohl die CPU Auslastung extrem niedrig ist und der Rechner subjektiv problemlos und schnell arbeitet, zeigt der top eine Load von über 4.00 an, da bin ich noch nicht dahinter gekommen, was daran schuld ist.
    Das passiert verbüffender Weise auch, wenn die Radeon im BIOS abgeschaltet (aber eingebaut) ist, der fglrx in der xorg.conf gar nicht vorkommt und die On-Board-Graphik die Ausgabe besorgt. Rätselhaft!